How do you make beams or lasers work in MSC?

Regorty

New Adventurer
MSC Developer
Joined
Dec 19, 2012
Messages
281
Reaction score
4
Age
29
As the title says, I can not figure out why my attempt at making beams in msc maps don't seem to work, even though I followed the tutorial on TWHL. :(
 

Thothie

Administrator
Staff member
Administrator
Moderator
MSC Archivist
Joined
Apr 8, 2005
Messages
16,342
Reaction score
326
Location
lost
Maybe a source and description of the exact issue?

It should be fairly simple, an env_beam with the "start entity" (LightningStart) defined as itself, and an "end entity" (LightningEnd) set to a specific info_target should create a beam between the two entities when the env_beam is triggered.

Beware that I think the default color for beams is 0 0 0 in the current Half-Life.fgd, and that may end you up with an invisible beam.

Beware, also, env_beam's are server side, and thus extremely resource intensive - damage done by beams may also lead to an "unclean" glitchy death.
 

Regorty

New Adventurer
MSC Developer
Joined
Dec 19, 2012
Messages
281
Reaction score
4
Age
29
Thothie said:
Maybe a source and description of the exact issue?

It should be fairly simple, an env_beam with the "start entity" (LightningStart) defined as itself, and an "end entity" (LightningEnd) set to a specific info_target should create a beam between the two entities when the env_beam is triggered.

Beware that I think the default color for beams is 0 0 0 in the current Half-Life.fgd, and that may end you up with an invisible beam.

Beware, also, env_beam's are server side, and thus extremely resource intensive - damage done by beams may also lead to an "unclean" glitchy death.
I don't think I have an info_target entity. Also the tutorial I used was:
http://twhl.info/tutorial.php?id=12
It includes a rmf to use as a reference. I tried taking the beam effects out of the file and placing it into my map and triggering it, but nothing happens.

I mostly plan to use the beam effects as temporary visuals that are only active for a couple seconds, just to add that little extra immersion.
 

Thothie

Administrator
Staff member
Administrator
Moderator
MSC Archivist
Joined
Apr 8, 2005
Messages
16,342
Reaction score
326
Location
lost
...well, simply copy-pasting a tutorial isn't the best way to go about learning from it. :?

The tutorial runs fine, however, so it seems you musta missed something while you were cheating on your exams.

In this case, the beams are following a func_train instead of an info_target, which makes the tutorial a bit more complicated - it maybe you only copied the beams and not their targets (the train itself is a brush entity, so maybe you just copied the point entities).

On a side note, it should also be possible to get a beam to follow a monster, if it has a targetname. (Also it seems MiB fixed that glitchy death thing I warned of awhile ago.)
 
Top